menu
#9718622 Access level to minijaham\PMEssentials\SpawnCommand::getOwningPlugin() must be public (as in class pocketmine\plugin\PluginOwned)

Submitted by PocketMine-MP 5.8.2

General information

Version: 5.8.2
Git commit: c3c81b09
Plugin involvement: Direct
Report date: 2023-12-03 04:53:01 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 0 seconds

System Information

PHP version: 8.1.24
JIT status: Not available
Operating system: win
System banner: Windows NT DESKTOP-QL64HUC 10.0 build 19045 (Windows 10) AMD64

Error information

Warning: the PMEssentials plugin was directly involved in this crash. Please contact the plugin author.
Thread: Main
Message: Access level to minijaham\PMEssentials\SpawnCommand::getOwningPlugin() must be public (as in class pocketmine\plugin\PluginOwned)
File: plugins/PMEssentials/src/commands/SpawnCommand
Line: #77
Type: E_COMPILE_ERROR
68
69
70
71
72
73
74
75
76
77
78
79
80
81

return true;
}

/**
* Get Loader Instance
*
* @return Loader
*/
protected function getOwningPlugin(): Loader
{
return $this->plugin;
}
}

Loaded Plugins

  • Show

Server Settings

  • Show

Installed Composer Dependencies

Installed PHP Extensions

  • Show