menu
#7862308 Declaration of SuperStulle007\UltraCapes\Main::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void

Submitted by PocketMine-MP 4.10.1

General information

Version: 4.10.1
Git commit: a39938e6
Plugin involvement: Direct
Report date: 2022-11-24 13:07:01 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 0 seconds

System Information

PHP version: 8.0.22
JIT status: Disabled
Operating system: linux
System banner: Linux 899f6b4c-7a01-4a15-b6a6-bae887b54bc7 5.10.0-0.bpo.9-amd64 #1 SMP Debian 5.10.70-1~bpo10+1 (2021-10-10) x86_64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of SuperStulle007\UltraCapes\Main::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void
File: plugins/Plugin - Cape/src/SuperStulle007/UltraCapes/Main
Line: #43
Error level: E_COMPILE_ERROR
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
use pocketmine\plugin\PluginBase;
use pocketmine\command\ConsoleCommandSender;
use pocketmine\utils\Config;
use SuperStulle007\UltraCapes\libs\jojoe77777\FormAPI\SimpleForm;

class Main extends PluginBase implements Listener {

protected $skin = [];

public function onEnable() {
$this->getServer()->getPluginManager()->registerEvents($this, $this);
$this->saveResource("config.yml");
$capes = new Config($this->getDataFolder() . "config.yml", Config::YAML);
if(is_array($capes->get("standard_capes"))) {
foreach($capes->get("standard_capes") as $cape){
$this->saveResource("$cape.png");
}
$capes->set("standard_capes", "done");
$capes->save();
}

Loaded Plugins

  • Show

Server Settings

  • Show

Installed PHP Extensions

  • Show