menu
#7557722 Declaration of Coins\Manager::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void

Submitted by PocketMine-MP 4.9.0

General information

Version: 4.9.0
Git commit: 785dc712
Plugin involvement: Direct
Report date: 2022-09-23 04:18:31 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 0 seconds

System Information

PHP version: 8.0.22
JIT status: Disabled
Operating system: linux
System banner: Linux 0729771b-3252-4413-b4eb-d1d42f958ee7 5.4.0-124-generic #140-Ubuntu SMP Thu Aug 4 02:23:37 UTC 2022 x86_64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of Coins\Manager::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void
File: plugins/DarkCoins/src/Coins/Manager
Line: #22
Error level: E_COMPILE_ERROR
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
use pocketmine\plugin\PluginBase;

class Manager extends PluginBase implements Listener {

/**
* @var
*/
public $eco;

public function onEnable()
{
$this->getLogger()->alert("Author ItsDarkEz for UniquePlugins");
$this->getServer()->getPluginManager()->registerEvents($this, $this);
$this->eco = $this->getServer()->getPluginManager()->getPlugin("EconomyAPI");
}

/**
* @param EntityDeathEvent $event
*/
public function onDeath(EntityDeathEvent $event){

Loaded Plugins

  • Show

Server Settings

  • Show

Installed PHP Extensions

  • Show