menu
#6720590 Declaration of SSUEE\OreDrop::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void

Submitted by PocketMine-MP 4.3.2

General information

Version: 4.3.2
Git commit: 755ca1af
Plugin involvement: Direct
Report date: 2022-05-14 10:54:28 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 0 seconds

System Information

PHP version: 8.0.13
Operating system: linux
System banner: Linux ip135-148-6-172 4.15.0-175-generic #184-Ubuntu SMP Thu Mar 24 17:48:36 UTC 2022 x86_64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of SSUEE\OreDrop::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void
File: plugins/OreDrop.phar/src/SSUEE/OreDrop
Line: #22
Error level: E_COMPILE_ERROR
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
use pocketmine\Player;

use pocketmine\event\Listener;
use pocketmine\event\block\BlockBreakEvent;

class OreDrop extends PluginBase implements Listener{

private $config;

public function onEnable(){
$this->getServer()->getPluginManager()->registerEvents($this, $this);
@mkdir($this->getDataFolder());
$this->saveResource("Config.yml");
$this->config = (new Config($this->getDataFolder(). "Config.yml", Config::YAML))->getAll();
Enchant::register();
}

public function onBreak(BlockBreakEvent $event){
$player = $event->getPlayer();
if($event->isCancelled()){

Loaded Plugins

  • Show

Server Settings

  • Show

Installed PHP Extensions

  • Show