menu
#5777720 Declaration of Arena\Main::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void

Submitted by PocketMine-MP 4.0.6

General information

Version: 4.0.6
Git commit: f7d25f25
Plugin involvement: Direct
Report date: 2022-01-15 01:04:50 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 0 seconds

System Information

PHP version: 8.0.13
Operating system: win
System banner: Windows NT DESKTOP-FNP8K1D 10.0 build 22000 (Windows 10) AMD64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of Arena\Main::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void
File: plugins/Arena.phar/src/Arena/Main
Line: #9
Error level: E_COMPILE_ERROR
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
<?php

namespace Arena;

use pocketmine\plugin\PluginBase;

class Main extends PluginBase{

public function onEnable(){
$this->getLogger()->info("Das Plagin wurde erfolgreich aktiviert!");
$this->getLogger()->emergency("Das Plugin hat ein Problem!");
}

public function onDisable(){
$this->getLogger()->info("Das Plugin wurde deaktivirt!");
}
}

Loaded Plugins

  • Show

Server Settings

  • Show

Installed PHP Extensions

  • Show