menu
#5777577 Declaration of aliuly\manyworlds\Main::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void

Submitted by PocketMine-MP 4.0.6

General information

Version: 4.0.6
Git commit: f7d25f25
Plugin involvement: Direct
Report date: 2022-01-15 00:02:36 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 0 seconds

System Information

PHP version: 8.0.13
Operating system: linux
System banner: Linux c424196a-3e73-4c5c-b49e-db91412d762b 5.4.0-94-generic #106-Ubuntu SMP Thu Jan 6 23:58:14 UTC 2022 x86_64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of aliuly\manyworlds\Main::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void
File: plugins/ManyWorlds (1).phar/src/aliuly/manyworlds/Main
Line: #18
Error level: E_COMPILE_ERROR
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
use aliuly\manyworlds\common\BasicPlugin;
use aliuly\manyworlds\common\mc;
use aliuly\manyworlds\common\MPMU;
use pocketmine\command\Command;
use pocketmine\command\CommandExecutor;
use pocketmine\command\CommandSender;

class Main extends BasicPlugin implements CommandExecutor{

public function onEnable(){
// We don't really need this...
//if (!is_dir($this->getDataFolder())) mkdir($this->getDataFolder());
mc::plugin_init($this, $this->getFile());

$this->modules = [];
foreach([
"MwTp",
"MwLs",
"MwCreate",
"MwGenLst",

Loaded Plugins

  • Show

Server Settings

  • Show

Installed PHP Extensions

  • Show