menu
#5777211 Cannot use non-existing permission "maxenchants.enchant"

Submitted by PocketMine-MP 4.0.6

General information

Version: 4.0.6
Git commit: f7d25f25
Plugin involvement: Indirect
Report date: 2022-01-14 22:15:46 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 1 seconds

System Information

PHP version: 8.0.13
Operating system: linux
System banner: Linux 58878ccf299c 5.4.0-73-generic #82-Ubuntu SMP Wed Apr 14 17:39:42 UTC 2021 x86_64

Error information

Warning: the MaxEnchants plugin was indirectly involved in this crash. This may be a false positive. Please contact the plugin author before opening a bug ticket.
Message: Cannot use non-existing permission "maxenchants.enchant"
File: pmsrc/src/command/Command
Line: #107
Error level: InvalidArgumentException
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117

public function getPermission() : ?string{
return $this->permission;
}

public function setPermission(?string $permission) : void{
if($permission !== null){
foreach(explode(";", $permission) as $perm){
if(PermissionManager::getInstance()->getPermission($perm) === null){
throw new \InvalidArgumentException("Cannot use non-existing permission \"$perm\"");
}
}
}
$this->permission = $permission;
}

public function testPermission(CommandSender $target, ?string $permission = null) : bool{
if($this->testPermissionSilent($target, $permission)){
return true;
}
#0 plugins/MaxEnchants.phar/src/Xenophilicy/MaxEnchants/MaxEnchants(106): pocketmine\command\Command->setPermission(string[19] maxenchants.enchant)
#1 pmsrc/src/plugin/PluginBase(137): Xenophilicy\MaxEnchants\MaxEnchants->onEnable()
#2 pmsrc/src/plugin/PluginManager(438): pocketmine\plugin\PluginBase->onEnableStateChange(true)
#3 pmsrc/src/Server(1383): pocketmine\plugin\PluginManager->enablePlugin(object Xenophilicy\MaxEnchants\MaxEnchants#23461)
#4 pmsrc/src/Server(1009): pocketmine\Server->enablePlugins(object pocketmine\plugin\PluginEnableOrder#23437)
#5 pmsrc/src/PocketMine(303): pocketmine\Server->__construct(object BaseClassLoader#3, object pocketmine\utils\MainLogger#2, string[8] /server/, string[16] /server/plugins/)
#6 pmsrc/src/PocketMine(326): pocketmine\server()
#7 pmsrc(11): require(string[45] phar:///server/server.phar/src/PocketMine.php)

Loaded Plugins

  • Show

Server Settings

  • Show

Installed PHP Extensions

  • Show