menu
#5776832 Declaration of Wanny\Nephtys\Core::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void

Submitted by PocketMine-MP 4.0.5

General information

Version: 4.0.5
Git commit: e7d17eb4
Plugin involvement: Direct
Report date: 2022-01-14 20:41:02 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 0 seconds

System Information

PHP version: 8.0.13
Operating system: linux
System banner: Linux heveenmc 5.4.140-1-pve #1 SMP PVE 5.4.140-1 (Wed, 08 Sep 2021 16:21:59 +0200) x86_64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of Wanny\Nephtys\Core::onEnable() must be compatible with pocketmine\plugin\PluginBase::onEnable(): void
File: plugins/NephtysElo/src/Wanny/Nephtys/Core
Line: #30
Error level: E_COMPILE_ERROR
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
use Wanny\Nephtys\Listener\NephysListener;
use Wanny\Nephtys\provider\ProviderInterface;
use Wanny\Nephtys\provider\providers\SQLiteProvider;
use Wanny\Nephtys\provider\providers\YamlProvider;
use Wanny\Nephtys\utils\EloSystem;

class Core extends PluginBase implements Listener{
private $provider;
private static $instance;
public function onEnable()
{
self::$instance = $this;
$this->getServer()->getPluginManager()->registerEvents($this, $this);
$this->setProvider();
$this->initEvents();
$this->initCommands();
$this->getLogger()->info("ยง6NephtysElo ON - By Wanny");
}

public function initEvents() : void {

Loaded Plugins

  • Show

Server Settings

  • Show

Installed PHP Extensions

  • Show