menu
#5038621 Declaration of GeoIP\API\CommandAPI::getUsage() must be compatible with pocketmine\command\Command::getUsage(): string

Submitted by PocketMine-MP 3.22.0

General information

Version: 3.22.0
Git commit: c32c2146
Plugin involvement: Direct
Report date: 2021-07-22 04:51:08 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 1 seconds

System Information

PHP version: 7.4.15
Operating system: linux
System banner: Linux 2787b8c49c99 4.19-ovh-xxxx-std-ipv6-64 #1613309 SMP Mon Jan 25 08:31:58 UTC 2021 x86_64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of GeoIP\API\CommandAPI::getUsage() must be compatible with pocketmine\command\Command::getUsage(): string
File: plugins/GeoIP2_dev-1.phar/src/GeoIP/API/CommandAPI
Line: #47
Error level: E_COMPILE_ERROR
38
39
40
41
42
43
44
45
46
47
48
49
50
            $message = "[Error] Please run this command in-game";
}else{
$message = $this->consoleUsageMessage;
}
return $message;
}
/**
* @return string
*/
public function getUsage(){
return parent::getUsage();
}
}

Loaded Plugins

  • Show

Server Settings

  • Show