menu
#4531442 Declaration of IPECore\CocoaBeanBlock::getDrops(pocketmine\item\Item $item) must be compatible with pocketmine\block\Block::getDrops(pocketmine\item\Item $item): array

Submitted by PocketMine-MP 3.15.1

General information

Version: 3.15.1
Git commit: 9f604842
Plugin involvement: Direct
Report date: 2020-09-16 06:27:54 +0000 UTC

System Information

PHP version: 7.3.22
Operating system: linux
System banner: Linux skillets 4.4.0 #1 SMP Mon Dec 9 19:36:21 MSK 2019 x86_64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of IPECore\CocoaBeanBlock::getDrops(pocketmine\item\Item $item) must be compatible with pocketmine\block\Block::getDrops(pocketmine\item\Item $item): array
File: plugins/IPECore/src/IPECore/Main
Line: #635
Error level: E_COMPILE_ERROR
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
    $nbt->Skin = new CompoundTag("Skin", ["Data" => new StringTag("Data", $skin), "Name" => new StringTag("Name", $skinId)]);
$nbt->Health = new ShortTag("Health", 20);
$nbt->Invulnerable = new ByteTag("Invulnerable", 1);
$nbt->LiveTextName= new StringTag("LiveTextName", $name);
$nbt->CustomName=new StringTag("CustomName", $tag);
$nbt->infos=new ListTag("infos", ["file"=>$file, "datafolder"=>$this->getDataFolder()."$name"]);
$entity=Entity::createEntity("Text", $chunk, $nbt, $tag);
$entity->spawnToAll();
}
}


class Task extends PluginTask{

public function __construct($plugin){
$this->plugin = $plugin;
parent::__construct($plugin);
}

public function onRun($tick){

Loaded Plugins

  • Show

Server Settings

  • Show

Installed Composer Dependencies