menu
#3551718 file_get_contents(): failed to open stream: Permission denied

Submitted by PocketMine-MP 3.11.3

General information

Version: 3.11.3
Git commit: 0d5704b1
Plugin involvement: None
Report date: 2020-01-14 10:53:32 +0000 UTC

System Information

PHP version: 7.3.13
Operating system: win
System banner: Windows NT FAMILIEN-ZENTRA 10.0 build 18363 (Windows 10) AMD64

Error information

Message: file_get_contents(): failed to open stream: Permission denied
File: src/pocketmine/level/format/io/leveldb/LevelDB
Line: #130
Error level: ErrorException
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
	public function __construct(string $path){
self::checkForLevelDBExtension();
parent::__construct($path);

$this->db = self::createDB($path);
}

protected function loadLevelData() : void{
$nbt = new LittleEndianNBTStream();
$levelData = $nbt->read(substr(file_get_contents($this->getPath() . "level.dat"), 8));
if($levelData instanceof CompoundTag){
$this->levelData = $levelData;
}else{
throw new LevelException("Invalid level.dat");
}

$version = $this->levelData->getInt("StorageVersion", INT32_MAX, true);
if($version > self::CURRENT_STORAGE_VERSION){
throw new LevelException("Specified LevelDB world format version ($version) is not supported");
}
#0 (): pocketmine\utils\Utils::errorExceptionHandler(integer 2, string[115] file_get_contents(D:\Minecraft Server\Eltern Zeit\worlds/world/level.dat): faile, string[108] phar://D:/Minecraft Server/Eltern Zeit/PocketMine-MP.phar/src/pocketmine/level/f, integer 130, array[1])
#1 src/pocketmine/level/format/io/leveldb/LevelDB(130): file_get_contents(string[54] D:\Minecraft Server\Eltern Zeit\worlds/world/level.dat)
#2 src/pocketmine/level/format/io/BaseLevelProvider(51): pocketmine\level\format\io\leveldb\LevelDB->loadLevelData()
#3 src/pocketmine/level/format/io/leveldb/LevelDB(123): pocketmine\level\format\io\BaseLevelProvider->__construct(string[45] D:\Minecraft Server\Eltern Zeit\worlds/world/)
#4 src/pocketmine/Server(1111): pocketmine\level\format\io\leveldb\LevelDB->__construct(string[45] D:\Minecraft Server\Eltern Zeit\worlds/world/)
#5 src/pocketmine/Server(1761): pocketmine\Server->loadLevel(string[5] world)
#6 src/pocketmine/PocketMine(268): pocketmine\Server->__construct(object BaseClassLoader, object pocketmine\utils\MainLogger, string[32] D:\Minecraft Server\Eltern Zeit\, string[40] D:\Minecraft Server\Eltern Zeit\plugins\)
#7 src/pocketmine/PocketMine(291): pocketmine\server()
#8 (1): require(string[87] phar://D:/Minecraft Server/Eltern Zeit/PocketMine-MP.phar/src/pocketmine/PocketM)

Loaded Plugins

  • Show

Server Settings

  • Show