menu
#3237187 Declaration of form\Main::getConfig($config) must be compatible with pocketmine\plugin\PluginBase::getConfig(): pocketmine\utils\Config

Submitted by PocketMine-MP 3.9.2

General information

Version: 3.9.2
Git commit: 7a747d6f
Plugin involvement: Direct
Report date: 2019-12-01 08:15:31 +0000 UTC

System Information

PHP version: 7.2.16
Operating system: win
System banner: Windows NT DESKTOP-NK1U71L 10.0 build 17763 (Windows 10) AMD64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of form\Main::getConfig($config) must be compatible with pocketmine\plugin\PluginBase::getConfig(): pocketmine\utils\Config
File: plugins/form/src/form/Main
Line: #29
Error level: E_COMPILE_ERROR
20
21
22
23
24
25
26
27
28
29
	public function getInstance($instance)
{
$this->instance = $instance;
}

public function getConfig($config)
{
$this->config = $config;
}
}

Loaded Plugins

  • Show

Server Settings

  • Show