menu
#3224660 Declaration of clan\window\Window::onOpen(pocketmine\Player $player) must be compatible with pocketmine\inventory\ContainerInventory::onOpen(pocketmine\Player $who): void

Submitted by PocketMine-MP 3.9.1

General information

Version: 3.9.1
Git commit: aaa01bb6
Plugin involvement: Direct
Report date: 2019-11-29 03:26:11 +0000 UTC

System Information

PHP version: 7.2.12
Operating system: linux
System banner: Linux sd-us1 3.10.0-1062.1.1.el7.x86_64 #1 SMP Fri Sep 13 22:55:44 UTC 2019 x86_64

Error information

Warning: the Clan plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of clan\window\Window::onOpen(pocketmine\Player $player) must be compatible with pocketmine\inventory\ContainerInventory::onOpen(pocketmine\Player $who): void
File: plugins/Clan.phar/src/clan/window/Window
Line: #107
Error level: E_COMPILE_ERROR
98
99
100
101
102
103
104
105
106
107
108
		if($player->getWindowId($this) !== -1){
parent::onClose($player);
}
}

public function getNetworkType() : int
{
return 0;
}
}
?>

Loaded Plugins

  • Show

Server Settings

  • Show