menu
#3080900 Declaration of MyPlot\MyPlotGenerator::__construct(pocketmine\level\ChunkManager $level, int $seed, array $options = Array) must be compatible with pocketmine\level\generator\Generator::__construct(array $settings = Array)

Submitted by PocketMine-MP 3.9.6

General information

Version: 3.9.6
Git commit: d1b70bd4
Plugin involvement: Direct
Report date: 2019-11-08 12:34:24 +0000 UTC

System Information

PHP version: 7.2.18
Operating system: linux
System banner: Linux kvm-daemon30-ny.virmach.com 4.9.0-4-amd64 #1 SMP Debian 4.9.65-3+deb9u1 (2017-12-23) x86_64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of MyPlot\MyPlotGenerator::__construct(pocketmine\level\ChunkManager $level, int $seed, array $options = Array) must be compatible with pocketmine\level\generator\Generator::__construct(array $settings = Array)
File: plugins/Arsa.phar/src/MyPlot/MyPlotGenerator
Line: #183
Error level: E_COMPILE_ERROR
174
175
176
177
178
179
180
181
182
183
    public function populateChunk(int $chunkX, int $chunkZ): void{
}

/**
* @return Vector3
*/
public function getSpawn(): Vector3{
return new Vector3(0, $this->groundHeight + 1, 0);
}
}

Loaded Plugins

  • Show

Server Settings

  • Show