menu
#3080873 Declaration of jasonwynn10\murder\commands\MurderMystery::getPlugin() must be compatible with pocketmine\command\PluginCommand::getPlugin(): pocketmine\plugin\Plugin

Submitted by PocketMine-MP 3.9.7

General information

Version: 3.9.7
Git commit: 0c91d568
Plugin involvement: Direct
Report date: 2019-11-08 12:24:46 +0000 UTC

System Information

PHP version: 7.3.11
Operating system: linux
System banner: Linux e84b24dc-55be-4669-82da-3f7fa34cd540 4.15.0-1047-gcp #50-Ubuntu SMP Wed Oct 2 00:50:34 UTC 2019 x86_64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of jasonwynn10\murder\commands\MurderMystery::getPlugin() must be compatible with pocketmine\command\PluginCommand::getPlugin(): pocketmine\plugin\Plugin
File: plugins/MurderMysteryPMMP-master/src/jasonwynn10/murder/commands/MurderMystery
Line: #45
Error level: E_COMPILE_ERROR
36
37
38
39
40
41
42
43
44
45
		return false;
}

/**
* @return Main|\pocketmine\plugin\Plugin
*/
public function getPlugin() {
return parent::getPlugin();
}
}

Loaded Plugins

  • Show

Server Settings

  • Show