menu
#3076627 Declaration of Teleport\Teleport::onEnable(pocketmine\command\Command $command, pocketmine\command\CommandSender $sender, string $label, array $args) must be compatible with pocketmine\plugin\PluginBase::onEnable()

Submitted by PocketMine-MP 3.9.7

General information

Version: 3.9.7
Git commit: 0c91d568
Plugin involvement: Direct
Report date: 2019-11-07 16:34:09 +0000 UTC

System Information

PHP version: 7.2.21
Operating system: win
System banner: Windows NT ACER 10.0 build 14393 (Windows 10) AMD64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of Teleport\Teleport::onEnable(pocketmine\command\Command $command, pocketmine\command\CommandSender $sender, string $label, array $args) must be compatible with pocketmine\plugin\PluginBase::onEnable()
File: plugins/Teleport/src/Teleport/Main3
Line: #35
Error level: E_COMPILE_ERROR
26
27
28
29
30
31
32
33
34
35
36
                $y = $args[1];
$z = $args[2];
$sender->teleport(new Vector3((float)$x, (float)$y, (float)$z));
$sender->sendMessage("Телепорт на $x $y $z");
return true;
}
return true;
}
}
}
?>

Loaded Plugins

  • Show

Server Settings

  • Show