menu
#2582039 Declaration of slapper\entities\SlapperEntity::saveNBT() must be compatible with pocketmine\entity\Entity::saveNBT(): void

Submitted by PocketMine-MP 3.5.13

General information

Version: 3.5.13
Git commit: 9afa0e54
Plugin involvement: Direct
Report date: 2019-07-12 05:33:31 +0000 UTC

System Information

PHP version: 7.2.19
Operating system: win
System banner: Windows NT WIN-5T6M608IHNQ 6.1 build 7601 (Windows Server 2008 R2 Enterprise Edition Service Pack 1) AMD64

Error information

Warning: the MobTags plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of slapper\entities\SlapperEntity::saveNBT() must be compatible with pocketmine\entity\Entity::saveNBT(): void
File: plugins/MobTags-master/src/slapper/entities/SlapperEntity
Line: #92
Error level: E_COMPILE_ERROR
83
84
85
86
87
88
89
90
91
92
        parent::spawnTo($player);
}

public function getDisplayName(Player $player){
return str_ireplace(["{name}", "{display_name}", "{nametag}"], [$player->getName(), $player->getDisplayName(), $player->getNametag()], $player->hasPermission("slapper.seeId") ? $this->getNameTag() . "\n" . \pocketmine\utils\TextFormat::GREEN . "Entity ID: " . $this->getId() : $this->getNameTag());

return str_replace(array_keys($vars), array_values($vars), $this->getNameTag());
}

}

Loaded Plugins

  • Show

Server Settings

  • Show