menu
#2581024 Declaration of FaigerSYS\CID\MPCommand::getPlugin() must be compatible with pocketmine\command\PluginIdentifiableCommand::getPlugin(): pocketmine\plugin\Plugin

Submitted by PocketMine-MP 3.8.0

General information

Version: 3.8.0
Git commit: 088fbf65
Plugin involvement: Direct
Report date: 2019-07-11 20:25:45 +0000 UTC

System Information

PHP version: 7.2.13
Operating system: linux
System banner: Linux gs75069 4.15.0-54-generic #58-Ubuntu SMP Mon Jun 24 10:55:24 UTC 2019 x86_64

Error information

Warning: the CID plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of FaigerSYS\CID\MPCommand::getPlugin() must be compatible with pocketmine\command\PluginIdentifiableCommand::getPlugin(): pocketmine\plugin\Plugin
File: plugins/CID.phar/src/FaigerSYS/CID/MPCommand
Line: #12
Error level: E_COMPILE_ERROR
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22

use pocketmine\command\Command;
use pocketmine\command\CommandSender;
use pocketmine\command\PluginIdentifiableCommand;

use pocketmine\event\TranslationContainer;

use pocketmine\Player;

class MPCommand extends Command implements PluginIdentifiableCommand {

/** @var CID */
private $plugin;

/** @var string[] */
private $skin_commands = [];

/** @var string[] */
private $cid_commands = [];

Loaded Plugins

  • Show

Server Settings

  • Show