menu
#2471067 Declaration of HealthBar\HealthBarCommand::getPlugin() must be compatible with pocketmine\command\PluginIdentifiableCommand::getPlugin(): pocketmine\plugin\Plugin

Submitted by PocketMine-MP 3.8.4

General information

Version: 3.8.4
Git commit: a42f68d3
Plugin involvement: Direct
Report date: 2019-06-12 14:22:40 +0000 UTC

System Information

PHP version: 7.2.8
Operating system: linux
System banner: Linux e843b3654f5b 4.9.177-xxxx-std-ipv6-64 #721950 SMP Fri May 17 08:31:25 UTC 2019 x86_64

Error information

Warning: the HealthBar plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of HealthBar\HealthBarCommand::getPlugin() must be compatible with pocketmine\command\PluginIdentifiableCommand::getPlugin(): pocketmine\plugin\Plugin
File: plugins/162-HealthBar-586a3.phar/src/HealthBar/HealthBarCommand
Line: #10
Error level: E_COMPILE_ERROR
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
<?php
namespace HealthBar;

use pocketmine\command\Command;
use pocketmine\command\CommandSender;
use pocketmine\command\PluginIdentifiableCommand;
use pocketmine\Player;
use pocketmine\utils\TextFormat;

class HealthBarCommand extends Command implements PluginIdentifiableCommand{
public $plugin;

public function __construct(Loader $plugin){
parent::__construct("healthbar", "Toggle HealthBar", "Usage: /healthbar <style|position|toggle>", ["hbar"]);
$this->setPermission("healthbar.command");
$this->plugin = $plugin;
}

public function getPlugin(){
return $this->plugin;

Loaded Plugins

  • Show

Server Settings

  • Show