menu
#2387599 Declaration of BEcraft\Balloon\NewVillager::initEntity() must be compatible with pocketmine\entity\Villager::initEntity(): void

Submitted by PocketMine-MP 3.8.1

General information

Version: 3.8.1
Git commit: 7521160f
Plugin involvement: Direct
Report date: 2019-05-15 19:34:05 +0000 UTC

System Information

PHP version: 7.2.5
Operating system: win
System banner: Windows NT DESKTOP-2J6IEO4 10.0 build 17763 (Windows 10) AMD64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Message: Declaration of BEcraft\Balloon\NewVillager::initEntity() must be compatible with pocketmine\entity\Villager::initEntity(): void
File: plugins/Balloon
Line: #150
Error level: E_COMPILE_ERROR
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
  class NewVillager extends Villager{

public function initEntity(){
parent::initEntity();
$this->setDataProperty(self::DATA_SCALE, self::DATA_TYPE_FLOAT, 0.1);
$this->setDataFlag(self::DATA_FLAGS, self::DATA_FLAG_BABY, true); //shh xD
$this->setDataFlag(self::DATA_FLAGS, self::DATA_FLAG_INVISIBLE, true);
}

}

class NewFallingSand extends FallingSand{

protected $gravity = 0.0;
protected $drag = 0.0;

public function onUpdate($currentTick){
return true;
}

Loaded Plugins

  • Show

Server Settings

  • Show