menu
#10302629 Unable to resolve "flint_and_steal" to a valid item

Submitted by PocketMine-MP 5.11.0

General information

Version: 5.11.0
Git commit: ce8fecc6
Plugin involvement: Direct
Report date: 2024-02-12 19:13:29 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 4 seconds

System Information

PHP version: 8.1.22
JIT status: Not available
Operating system: linux
System banner: Linux vps630912 4.15.0-213-generic #224-Ubuntu SMP Mon Jun 19 13:30:12 UTC 2023 x86_64

Error information

Warning: the NoCraftItem plugin was directly involved in this crash. Please contact the plugin author.
Thread: Main
Message: Unable to resolve "flint_and_steal" to a valid item
File: plugins/NoCraftItem_dev-6.phar/src/NhanAZ/NoCraftItem/libs/NhanAZ/libBedrock/StringToItem
Line: #19
Type: NhanAZ\NoCraftItem\libs\NhanAZ\libBedrock\libBedrockException
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
use pocketmine\item\StringToItemParser;
use NhanAZ\NoCraftItem\libs\NhanAZ\libBedrock\libBedrockException;

class StringToItem {

public static function parse(string $string): Item {
try {
$item = StringToItemParser::getInstance()->parse($string) ?? LegacyStringToItemParser::getInstance()->parse($string);
} catch (LegacyStringToItemParserException $e) {
throw new libBedrockException($e->getMessage());
}
if (!$item instanceof Item) {
throw new libBedrockException("\"{$string}\" is not a item!");
}
return $item;
}
}
#0 plugins/NoCraftItem_dev-6.phar/src/NhanAZ/NoCraftItem/Main(19): NhanAZ\NoCraftItem\libs\NhanAZ\libBedrock\StringToItem::parse(string[15] flint_and_steal)
#1 pmsrc/src/plugin/PluginBase(119): NhanAZ\NoCraftItem\Main->onEnable()
#2 pmsrc/src/plugin/PluginManager(454): pocketmine\plugin\PluginBase->onEnableStateChange(true)
#3 pmsrc/src/Server(1407): pocketmine\plugin\PluginManager->enablePlugin(object NhanAZ\NoCraftItem\Main#142896)
#4 pmsrc/src/Server(1036): pocketmine\Server->enablePlugins(object pocketmine\plugin\PluginEnableOrder#45273)
#5 pmsrc/src/PocketMine(341): pocketmine\Server->__construct(object pocketmine\thread\ThreadSafeClassLoader#3, object pocketmine\utils\MainLogger#6, string[12] /home/storm/, string[20] /home/storm/plugins/)
#6 pmsrc/src/PocketMine(364): pocketmine\server()
#7 pmsrc(11): require(string[56] phar:///home/storm/PocketMine-MP.phar/src/PocketMine.php)

Loaded Plugins

  • Show

Server Settings

  • Show

Installed Composer Dependencies

Installed PHP Extensions

  • Show