menu
#10302463 Declaration of DaniDev\LobbyCore\LobbyCore::onDisable() must be compatible with pocketmine\plugin\PluginBase::onDisable(): void

Submitted by PocketMine-MP 5.11.0

General information

Version: 5.11.0
Git commit: ce8fecc6
Plugin involvement: Direct
Report date: 2024-02-12 18:32:16 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 1 seconds

System Information

PHP version: 8.2.13
JIT status: Not available
Operating system: win
System banner: Windows NT PCDIDANIEL 10.0 build 22631 (Windows 11) AMD64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Thread: Main
Message: Declaration of DaniDev\LobbyCore\LobbyCore::onDisable() must be compatible with pocketmine\plugin\PluginBase::onDisable(): void
File: plugins/DaniLobbyUI.phar/src/DaniDev/LobbyCore
Line: #51
Type: E_COMPILE_ERROR
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
            ]
]);

$this->loadConfigItems();

$this->getServer()->getPluginManager()->registerEvents($this, $this);
$this->lobbySpawn = $this->getServer()->getDefaultLevel()->getSpawnLocation();
}

public function onDisable() {
$this->getLogger()->info("LobbyCore has been disabled!");
}

public function onPlayerJoin(PlayerJoinEvent $event) {
$player = $event->getPlayer();
$this->teleportToLobby($player);
$this->giveLobbyItems($player);

$welcomeMessage = str_replace("{player}", $player->getName(), $this->config->get("lobby")["welcome-message"]);
$this->broadcastMessage($welcomeMessage);

Loaded Plugins

  • Show

Server Settings

  • Show

Installed Composer Dependencies

Installed PHP Extensions

  • Show