menu
#10302249 Class "overblast\core\events\PlayerMoveEvent" does not exist

Submitted by PocketMine-MP 5.7.0

General information

Version: 5.7.0
Git commit: 22b9e703
Plugin involvement: Indirect
Report date: 2024-02-12 17:45:00 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 0 seconds

System Information

PHP version: 8.1.22
JIT status: Not available
Operating system: linux
System banner: Linux bfc2defd-dc18-4c87-a6c4-7a4b5206a028 6.1.0-13-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.55-1 (2023-09-29) x86_64

Error information

Warning: the OB-Core plugin was indirectly involved in this crash. This may be a false positive. Please contact the plugin author before opening a bug ticket.
Thread: Main
Message: Class "overblast\core\events\PlayerMoveEvent" does not exist
File: pmsrc/src/plugin/PluginManager
Line: #574
Type: ReflectionException
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584

$paramType = $parameters[0]->getType();
//isBuiltin() returns false for builtin classes ..................
if(!$paramType instanceof \ReflectionNamedType || $paramType->isBuiltin()){
return null;
}

/** @phpstan-var class-string $paramClass */
$paramClass = $paramType->getName();
$eventClass = new \ReflectionClass($paramClass);
if(!$eventClass->isSubclassOf(Event::class)){
return null;
}

/** @var \ReflectionClass<Event> $eventClass */
return $eventClass->getName();
}

/**
* Registers all the events in the given Listener class
#0 pmsrc/src/plugin/PluginManager(574): ReflectionClass->__construct(string[37] overblast\core\events\PlayerMoveEvent)
#1 pmsrc/src/plugin/PluginManager(596): pocketmine\plugin\PluginManager->getEventsHandledBy(object ReflectionMethod#114498)
#2 plugins/OB-Core/src/overblast/core/main(51): pocketmine\plugin\PluginManager->registerEvents(object overblast\core\events\items#114695, object overblast\core\main#41785)
#3 pmsrc/src/plugin/PluginBase(119): overblast\core\main->onEnable()
#4 pmsrc/src/plugin/PluginManager(454): pocketmine\plugin\PluginBase->onEnableStateChange(true)
#5 pmsrc/src/Server(1390): pocketmine\plugin\PluginManager->enablePlugin(object overblast\core\main#41785)
#6 pmsrc/src/Server(1034): pocketmine\Server->enablePlugins(object pocketmine\plugin\PluginEnableOrder#41683)
#7 pmsrc/src/PocketMine(334): pocketmine\Server->__construct(object pocketmine\thread\ThreadSafeClassLoader#6, object pocketmine\utils\MainLogger#3, string[16] /home/container/, string[24] /home/container/plugins/)
#8 pmsrc/src/PocketMine(357): pocketmine\server()
#9 pmsrc(11): require(string[60] phar:///home/container/PocketMine-MP.phar/src/PocketMine.php)

Loaded Plugins

  • Show

Server Settings

  • Show

Installed Composer Dependencies

Installed PHP Extensions

  • Show