menu
#10302247 Declaration of weapons\WeaponPlugin::onLoad() must be compatible with pocketmine\plugin\PluginBase::onLoad(): void

Submitted by PocketMine-MP 5.10.0

General information

Version: 5.10.0
Git commit: daeba951
Plugin involvement: Direct
Report date: 2024-02-12 17:44:40 +0000 UTC
Server uptime: 0 days 0 hours 0 minutes 1 seconds

System Information

PHP version: 8.1.26
JIT status: Not available
Operating system: win
System banner: Windows NT SOARES 10.0 build 22621 (Windows 11) AMD64

Error information

Warning: a plugin was directly involved in this crash. Please contact the plugin author.
Thread: Main
Message: Declaration of weapons\WeaponPlugin::onLoad() must be compatible with pocketmine\plugin\PluginBase::onLoad(): void
File: plugins/Weapons_v0.1.phar/src/weapons/WeaponPlugin
Line: #51
Type: E_COMPILE_ERROR
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61

/**
* @return CooldownManager
*/
public function getCooldownManager(): CooldownManager
{
return $this->cooldownManager;
}

public function onLoad()
{
self::$instance = $this;
$this->reloadConfig();
$this->weaponManager = new WeaponManager();
$this->cooldownManager = new CooldownManager();
}

public function onEnable()
{
$this->getWeaponManager()->init($this->getConfig());

Loaded Plugins

  • Show

Server Settings

  • Show

Installed Composer Dependencies

Installed PHP Extensions

  • Show